Collaborate-NA Application Unavailable for all customers
Incident Report for Conga
Resolved
The Conga Team has implemented a fix to the issue. We continue to closely monitor the issue for any other related problems.
Posted Jun 02, 2020 - 14:42 MDT
Investigating
The Conga Team is working to isolate a complete disruption with Collaborate-NA. All customers are unable to access the application.
Posted Jun 02, 2020 - 14:35 MDT
This incident affected: Conga Collaborate - Americas.