Conga Sign processing delays in EMEA
Incident Report for Conga
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 10:04 MDT
Monitoring
The performance issue has been identified and a fix has been put in place. We are now monitoring for any further issues.
Posted Jun 29, 2020 - 09:59 MDT
Investigating
We are currently investigating reports of delays in processing Conga Sign transactions in EMEA.
Posted Jun 29, 2020 - 09:50 MDT
This incident affected: Conga Sign (Conga Sign - EMEA).