Conga Sign document processing delay
Incident Report for Conga
Resolved
Completed documents that had been delayed have been delivered and all services are operating as expected.
Posted Mar 18, 2021 - 16:29 MDT
Update
Documents are being processed but may still be delayed. We are continuing to monitor.
Posted Mar 18, 2021 - 15:08 MDT
Update
Documents are now being processed but may still be delayed. We are continuing to monitor.
Posted Mar 18, 2021 - 13:52 MDT
Monitoring
Documents are now being processed as expected. We are continuing to actively monitor.
Posted Mar 18, 2021 - 13:07 MDT
Identified
Documents are now being processed but may still be delayed. We are continuing to monitor.
Posted Mar 18, 2021 - 12:10 MDT
Update
The issue has been identified and we are continuing to work towards a resolution.
Posted Mar 18, 2021 - 10:56 MDT
Investigating
We are currently investigating a delay in processing documents in Conga Sign in North America and EMEA.
Posted Mar 18, 2021 - 09:46 MDT
This incident affected: Conga Sign (Conga Sign - Americas, Conga Sign - APAC, Conga Sign - EMEA).