Conga Sign Unavailable in North America
Incident Report for Conga
Resolved
This incident has been resolved. All services are working normally in all regions.
Posted Sep 25, 2019 - 15:18 MDT
Monitoring
We have identified and implemented a fix for the cause of the availability issue with Conga Sign in North America. We are monitoring the situation for any further disruptions.
Posted Sep 25, 2019 - 13:53 MDT
Investigating
We are investigating an issue with connecting to Conga Sign services in North America.
Posted Sep 25, 2019 - 13:31 MDT
This incident affected: Conga Sign (Conga Sign - Americas).