Delays Receiving Conga Sign Transaction Complete Emails
Incident Report for Conga
Resolved
All delayed Transaction Complete emails have been sent and Conga Sign is operating as normal.
Posted Mar 12, 2020 - 14:14 MDT
Investigating
We are beginning to see delays in generating Conga Sign final documents, starting around 12:35pm Mountain Time. This can result in very long wait times while trying to download the final document from Conga Sign after completing signature, and a delay in transaction completion emails.

We are again investigating and escalating and will provide an update as soon as we are able.
Posted Mar 12, 2020 - 12:59 MDT
This incident affected: Conga Sign (Conga Sign - Americas, Conga Sign - APAC, Conga Sign - EMEA).