Conga Sign document processing delay
Incident Report for Conga
Resolved
Document processing delays have been resolved.
Posted Jul 30, 2020 - 12:59 MDT
Monitoring
We have implemented a fix for the delayed document processing issue and are actively monitoring for any additional issues.
Posted Jul 30, 2020 - 11:58 MDT
Investigating
We are currently investigating a delay in processing documents in Conga Sign in North America. The Preview & Tag and Signing pages may be slow to load. Signing invitation emails are also delayed at this time.
Posted Jul 30, 2020 - 10:16 MDT
This incident affected: Conga Sign (Conga Sign - Americas).