Emails being delayed in Office365
Incident Report for Conga
Resolved
This incident has been resolved.
Posted May 07, 2020 - 15:05 MDT
Monitoring
O365 emails seem to be working without delay. We are continuing to monitor for additional delays.
Posted May 07, 2020 - 13:13 MDT
Investigating
Several users are currently experiencing a significant delay with their emails when using Office365. We are investigating the issue
Posted May 07, 2020 - 12:57 MDT
This incident affected: Conga Contracts (Conga Contracts - Americas 1, Conga Contracts - Americas 2).